[DeN26] Technical Issues
Incident Report for FinTecSystems
Resolved
This incident has been resolved.
Posted Mar 25, 2020 - 17:04 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 25, 2020 - 13:43 CET
Investigating
N26 Bank experiences periodical technical issues.
Posted Mar 25, 2020 - 13:42 CET