[DeIng] Technical Issues
Incident Report for FinTecSystems
Resolved
This incident has been resolved.
Posted May 12, 2020 - 08:59 CEST
Identified
[DeIng] experiences periodical technical issues.
Posted May 11, 2020 - 11:47 CEST
This incident affected: Banking Interfaces.