[N26] Technical Issues
Incident Report for FinTecSystems
Resolved
This incident has been resolved.
Posted Jun 12, 2020 - 12:09 CEST
Identified
[N26] has periodical technical issues.

No action is required by our customers.

Because of ongoing technical problems of the bank users may not be able to login or perform a successful transaction.

In case of ongoing errors or problems please contact
support@fintecsystems.com.
Posted Jun 10, 2020 - 11:42 CEST
This incident affected: Banking Interfaces.