[DeFiducia] Technical Issues
Incident Report for FinTecSystems
Resolved
This incident has been resolved.
Posted Apr 14, 2020 - 11:22 CEST
Identified
DeFiducia (Volksbanken and various other bank) experiences periodical technical issues.
Posted Jan 30, 2020 - 15:42 CET