[UsPayPal] Technical Issues
Incident Report for FinTecSystems
Resolved
This incident has been resolved.
Posted Mar 18, 2020 - 14:43 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 13, 2020 - 10:20 CET
Identified
[UsPayPal] has periodical technical issues.

No action is required by our customers.

Because of ongoing technical problems with the bank users may not be able to login or perform a successful transaction.

We might have to implement some changes in order to restore full functionality. We will do this as soon as the banks websites are fully functional again.

In case of ongoing errors or problems please contact
support@fintecsystems.com.
Posted Jan 17, 2020 - 13:32 CET
This incident affected: Banking Interfaces.